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Abstract

This documentation originated from the project work about LVDS
in the time of August 23rd 1999 till 5th November 1999. It describes
the programs used to create a printed circuit board. The programs
have the following functions:

• Protel is used to construct a wiring schematic and to turn it into
a real layout.

• CircuitCam prepares the layout from Protel for the LPKF Plot-
ter.

• BoardMaster is the controller software for the LPKF-Fräsbohrplot-
ter, which is available at the IHEP for the rapid prototyping of
PCB’s.

We had to learn the program Protel by doing, without a docu-
mentation. Thus we weren’t able to use all existing features of the
software, plainly by not knowing of their existence. Only project
relevant functions were used in the period of our LVDS design. This
shouldn’t be a too big of a restriction, because we hope to show you
the most common.

CircuitCAM and BoardMaster were shipped with the LPKF plot-
ter, so you should find plenty of documentation. Those programs
are rather voluminous (as Protel), so our intention is not to give a
complete documentation, but to summarize the steps we had to take
to get our PCB’s. That is why we used a processing circle of one
of our PCB’s to show exemplary the necessary steps involved. With
the LPKF we got excellent support from Ralf Achenbach, head of
the ASIC test laboratory. This wouldn’t have been possible without
him.



2

Further pieces of information can be obtained by the authors.
Their email is:

• Sascha Reinhardt sascha.reinhardt@urz.uni-heidelberg.de

• Marco Wilzbach PCB@Wilzbach.de

This PDF document will be available on the WWW:
http://www.wilzbach.de/PCB prototyping.html
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Chapter 1

Protel

1.1 Creating a new design

In order to create a new design in Protel you have to choose the Menu
item File->New Design... A window opens, where the directory,
the name and a password can be provided ( 1.1).

Figure 1.1: New Design Database
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1.1.1 Wiring schematic

To add a wiring schematic document you have to choose File->New....
Then there appears a list of available documents. Choose the ’Schematic
Document’. In the list you will also find all the other documents you
will need later ( 1.2). The new Schematic Document should apear in
the ’design files window’. You can rename it in the internal explorer
and also open it (if it isn’t already open).

Figure 1.2: New Document

1.1.2 Creating own components

Components for the wiring schematics are created in a Schematic
Library Document or are loaded from existing libraries. You will
get the Schematic Library Document as simple as the Schematic
Document.

With the tools you can create every component you will need.
Once you have selected a tool you can change the preferences of it
by pressing TAB . E.g. you do intend to create a component with
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pins on both sides of the component. You will have to swap the
orientation of the pins on one side, to have the name of the pins all
in/out of your component. It also can happen that the automatic
pin numbering does not provide the correct counter. E.g. you delete
a pin, and with the next pin the number is now too high. To solve
that problem you have to press TAB and then to modify the number.

To deactivate the current tool you have to press the right button
of your mouse.

Figure 1.3: Surface of the Schematic Library Document

Once a component is finished, you should choose Browser->Schlib
Description. A menu opens where you can change the name of the
component. An important point is the footprint data ( 1.4). You will
later need a corresponding ’real’ part, which you place in the layout,
with a footprint corresponding to your schematic component. Oth-
erwise the program is not able to translate schematics into layout.
You should choose simple and obvious names, for your own sake.
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Figure 1.4: Description window

1.1.3 Components on the wiring schematic

You have to switch to the Explorer->Schematic Document . Aside
the Explorer you will see the Browser Schlib . Select it and choose
Libraries . With Add/Remove you will add/remove the desired
library, e.g. your own library or prefabricated libraries. To add your
own, you have to choose your complete design document as a library
( 1.5).

The take along libraries of Protel are located \Protel99\Library\-
Sch\.

A library with standard components has the name Miscelloneous
Devices.ddb Once you clicked OK, you will be able to mark the
added library in the Browse window. If you select a library you
will get a list with available components. Just select the desired
component by a click and drag it to the schematic window. A left
click places the component onto your document. To deselect right
click. Now you can choose a component by clicking on it. Every
single component needs its own unique name.
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Figure 1.5: Selection of libraries

1.1.4 Connections with wires, busses and ports

There are three ways connecting components.

• You simply link the pins with the tool Wires ( 1.6).
Tool Wires

You use the tool as follows: With a left click you can set the
starting points and the fixed points of the wires (Similary to
polygon drawing in a graphics program). With a right click
you end the wire drawing mode, and you can start a different
connection. A second right click deactivates the wiring tool.
The starting/end point should be the end of a pin or a different
wire.

• With the tool Bus you can use a representation of many wires
by one thick wire. You can place it like the tool Wires. This
helps you to clearly arrange your connections. At the bus you
can place BusEntrys which then can be connected with pins by
wires. To let the program know which two BusEntrys are linked,
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you have to label them. You can label the adjacent wires or the
BusEntry itself. The corresponding tool is NetLabel. Just place
the same label at the two wires and they are connected ( 1.7).

Tool Bus

Tool NetLabel

By clicking twice onto a NetLabel you will get a menu for chang-
ing the preferences of the Label. If you use numbers with the
labels, they will automatically be incremented by one. The ori-
entation of a BusEntry (or any object) can be changed by press-
ing the keys x or y when having it dragged (hold left click) or
in the placing process.

• With Port you can connect pins. If you add a port to a pin you
will be able to name it. So all ports with the same name are
connected to each other. This option is preferably used with
power supply and ground. ( 1.8).

Tool Port

Figure 1.6: Connection with Wires
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Figure 1.7: Connection with a Bus

Figure 1.8: Connection with Ports
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Figure 1.9: Showing preferences of a component

1.1.5 Footprints

Each component needs a footprint for further use (some standard
already have one) ( 1.9).

The meaning of the footprints is to have a link between schematic
components and real PCB components. In the footprint library’s the
dimensions are given.

1.1.6 Power supply and ground

The power supply and the ground level are inserted with PowerPort
on the schematic. In the preferences card you can change the look
with Style. The option Net you can change the netname, e.g. GND
or V-CC. Here the name plays no role and is arbitrary. If you use
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different power supplies you have to place the desired quantity and to
name them differently, in order that they stay seperatly in the layout.

Tool PowerPort

1.1.7 ERC

When you have finished your wiring schematic you can let it check by
the program. You can use the electrical rule check Tools -> ERC...
to find errors, e.g. if a component has no name or is not connected.

1.2 From the wiring schematic to the PCB

The wiring schematic is something abstract and generally has noth-
ing to do with the placement in reality. E.g. you have crossing wires
on your schematic, but this wouldn’t do good on the PCB until it is
desired.

1.2.1 Creation of the Printed Circuit Board (PCB)

You simply have to open the window New Document. There you can
choose PCB Document. But if you already have an expectation to
your circuit board, you should choose the Wizard, which you also
find in New Document. There you can specify all desired options for
your PCB, step by step, e.g. the dimensions, number of layers.

1.2.2 Creating your own footprints

Choose in New Document the File PCB Library Document. There
you can add new components with their footprints by pressing Add.
By doing this a Component wizard assists you. ( 1.11).

You can choose the desired type. The next step is to enter the
dimensions, which usually are given in the data sheet of your compo-
nent. Does the wizard not contain your type of component you have
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Figure 1.10: ERC
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Figure 1.11: Wizard for generating new components

to create it manually. This works similar as in the wiring schematic.
The names of your footprints have to correspond to the names of the
schematic pins, to let the program know how it has to arrange all
the connections.

1.2.3 Updating the PCB

If all components in the schematic do have a corresponding compo-
nent in a PCB library, then you can let create the PCB. To do this,
you have to open the finished wiring schematic and to choose in the
menu Design the option Update PCB.... If there are more than one
PCB files you have to choose the right one to be updated.

If there are no errors, then all components and their connections
are on the PCB. The connections are displayed as thin lines, which
directly link the right (hopefully) footprints. If you created your
PCB with the wizard, then your components are usually outside of
the boundary line of your PCB.
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1.2.4 DRC

The Design Rule Check (DRC) is a support for the creation and
editing of a PCB. The rules for the DRC can be edited in the menu
Design -> Rules. There you can specify among other things the
minimal clearance between two traces and the minimal/maximum
width of your traces.

After the DRC you will get a report. Did you violate one of the
rules the problem will be described.

1.2.5 Autoroute and Autoplace

Autoplace: In the menu Tools -> Autoplace... you can also
use an automated placement of your components. With few
components it is usually easier to place them by hand.

Autoroute: In the menu Auto Rout are several options for au-
torouting. The simpliest is All. This one connects all wires
automatically. Important wires should be drawed by hand.

1.2.6 Drawing wires

Traces can be drawn with the tool ManualRouter. You just click on
a starting point, then on the next junction, analogously to the wires
in the schematic.

Tool ManualRouter

Once a trace has been drawn, it changes its colour (e.g. red to
yellow). A little help is that all traces according to the same net are
highlighted by the same colour (yellow) when selected.

1.2.7 Pads, Vias and other things

A Pad is an area on which SMD components are placed. Usually
these pads are created automatically in the placing process (when
you place a component). You shouldn’t choose to small pads, so
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that you can easy solder.

Tool Pads

Vias are drilled holes which are plated. They connect multiple
layers of your PCB. You should use as few as possible of them, be-
cause plating is a very ugly procedure (with our IHEP plotter).

Tool Vias

Another useful tool is Polygon Plane. Once you finished the
drawing of your PCB you can add a plane on your PCB, which is
poured over it. You usually connect the place to ground or power.
The advantage of the plane is, that you reduce the empty space
between the traces, thus taking care of the Universal cutter (a tool
of the LPKF plotter, with a weak durability), and to get it done
faster for the plotter.

If you are working with high speed, you should activate the op-
tion Remove dead copper. This removes the areas of copper, which
weren’t in a location to be connected to the selected net. That is
because isolated areas are likely to work as small antennas (EM),
thus disturbing other lines.

Tool Polygon Plane

1.3 The way from Protel to CircuitCAM

Is your PCB finished and without bugs, you can start exporting
your data to CircuitCAM, which prepares the data for the plotter.
CircuitCAM is the program for the LPKF plotter, and was shipped
with it, thus having a giant documentation.

1.3.1 Setup Printer and the Aperture Library

Once you have reached the state of an error free PCB, you can start
setting up the printer.

In the menu File->Setup Printer you get a selection of output
devices. You choose Protel Gerber RS274. Now you can select
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Figure 1.12: Selecton of the layers

Print, Options, Layers. First of all you should go to the Layers,
where you mark your desired layers, usually Top, Bottom, and In-
ternal Plane 1 for the drilling. The other layers should be deselected
( 1.12). Press OK.

Now you choose the Options where you first select Aperture
Library, to create the right apertures for your board. Selecting
Create List from PCB normally should do it. If you are working
with the LPKF plotter you should in advance deselect the Flash Pad
Shapes, which are only for an optical PCB processing (with photo
varnish). ( 1.13).

Then you close the options.

After you pressed print you have to specify a directory within your
Protel document, where the files should be stored (it is a good idea
to have an special directory created before the exporting step, e.g.
’plotter-files’).

When Protel is finished plotting the data you get two files for each
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Figure 1.13: Creating Apertures

layer. One aperture file (xxx.Ayy) and a gerber file (xxx.Gyy).

1.3.2 Exporting the files

The plotted files finally have to be exported out of the Protel archive
into the real file system. For that you mark all the created files
(in the plotting process) in the Protel Explorer and then press the
right mouse button. In the menu you choose Export.... Choose
the directory in the real file system and press OK. Now you could
profit from a ’plotter-files’ directory, since you could export the whole
directory.
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CircuitCAM

2.1 Foreword

CircuitCam is used for preparing the PCB raw data generated by
Protel into a format, which the LPKF plotter understands. In Cir-
cuitCAM you get the final possibility to change something of your
layout, even if that generally should be done in Protel. But minor
things are OK. Later in BoardMaster you can’t change the data. To
come to our resulting BoardMaster data, we need several steps to
take.

2.2 Import of Protel files

Usually when you generate your output files in Protel, you get two
files for each layer, which are belonging to each other. E.g. if you
generated data for top layer, bottom layer and drills, then you should
have six files. There are two different kinds:

• Aperture files contain the data for the different tools you will
need in order to get the used structures worked out. E.g. dif-
ferent drills, or milling tools of varying size. These definitions
are needed before you can import the so called ’gerber’ files.
The file names have following structure: xxx.Ayy; where xxx

21
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is the filename in Protel. yy can stand for TL (Top layer), BL
(Bottom layer), P1 (Plated 1), possible are also other endings,
depending on the selected layers which were exported in Protel.

• Gerber files contain the contour data for the milling tools and
the hole positions for the drills. The file names have following
structure: xxx.Gyy

Bare in mind, that your first step is to import the aperture file
and then the corresponding gerber file.

2.2.1 Import of the apertures

To import the aperture file you have to choose Datei->Importieren
( 2.1).

Figure 2.1: Menu Import

Once you selected your directory with the exported protel files,
you will get a list with the aperture and the gerber files ( 2.2).



2.2. IMPORT OF PROTEL FILES 23

Figure 2.2: List of files
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Load the aperture file of your choice. Then you will get to another
window, where you have to name the aperture definitions file, to allow
the program to identify different aperture files. As name you should
use the ending Ayy of your current file, so it is easier for you to
arrange the gerber files later ( 2.3).

Figure 2.3: Name aperture file

For the Dateityp select Blenden/Werkzeuge, aut. Press OK.
Then you should get the message: xy apertures recognized ( 2.4).

Figure 2.4: Recognized message
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Now you could import the other aperture files repeating the steps
above, or you can go along to import you corresponding gerber file.

2.2.2 Import of the gerber data

Proceed like in importing the aperture files. Select Datei->Importieren,
then select a gerber file, whose aperture file you already imported
( 2.5).

Figure 2.5: Select gerber file

Then you get to the main import menu ( 2.6).
Gerber-X should already be selected. Then select your corre-

sponding aperture file. If you took my advice with importing the
apertures you just have to enter Ayy, where yy stands for the ending
from your gerber file xxx.Gyy. Also select the right layer. E.g. if
yy=TL then you should select Top layer, or yy=BL then select Bot-
tom layer. Protel usually uses different endings yy for each layer, so
that you can identify your exported layers clearly.

The result should look like ( 2.7), if you started with importing
the bottom layer.

Do the same with the remaining layers. The final result should
look like ( 2.8).
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Figure 2.6: Menu Import gerber

Figure 2.7: Result of importing bottom gerber
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Figure 2.8: Final result
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2.2.3 Errors with pad sizes

Sometimes it may happen, that a pad size was misinterpreted by the
program. E.g. your pads of your chip are too big (lucky if you realize
that in time). You could change these apertures by hand in Protel,
but usually you don’t know them in advance. If you have only a
few do it directly by hand. If there are more, change the aperture
definition. So click on one of these faulty pads. You will see a name
like D12 in the third column of the programs main window. This
is the aperture you have to edit. (The layer has to be markable in
order you can mark the pad. ( 2.14, 2.15)) Then select in the menu
Konfiguration->Format->Gerber Blendenliste... ( 2.9).

Figure 2.9: Loading Gerber Apertures
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Then select the aperture file, corresponding to the layer where you
encountered the error ( 2.10).

Figure 2.10: List of different aperture files

Then you get a list with all existing apertures ( 2.11).

Figure 2.11: List of apertures

Double click the faulty aperture. Then you will be able to edit it
( 2.12). You can delete it first, or you just can change its size.

Once you finished editing your aperture, save the changes, and
then go back to the main window ( 2.13).

Now the faulty pad(s) should be modified.
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Figure 2.12: Edit aperture

Figure 2.13: Change window
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2.3 Setting the drill size

Since protel doesn’t know the drills available with the LPKF plotter,
you have to set them in CircuitCAM.

2.3.1 Selecting the right layers

First of all you have to turn of all layers, except the drills. To get to
the layer selection menu press the Layers button ( 2.14)

Figure 2.14: Select the right layers

Then you will get to a screen, where you can select/deselect your
layers. ( 2.15).
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Figure 2.15: Select the right layers

There you should deselect all layers you don’t need. In the end
only layers you don’t have and the drills (plated/unplated) may be
selected. In order that you will be able to mark the drills you also
have to select Markierbar. It is always good to have that option
on.

2.3.2 Adjusting the hole size

You have to start with marking the holes you want to adjust. In the
top of the CircuitCAM window are three columns ( 2.16).
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Figure 2.16: Adjusting hole size
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• In the first column you can select either the holes should be
plated or unplated.

• In the second column you have to choose the LPKF drilling
tools.

• In the third column you can choose the drill’s diameter.

2.3.3 Select layers

To finish the drills you finally have to select the other layers again,
which were deselected earlier ( 2.14, 2.15).
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2.4 Rubout layers

Now you have to prepare your PCB for the contour routing, which
defines the line for the cutting out. You have to draw a rectangle,
which covers up your PCB. All within the rectangle will be safe.
Later, the contour router will go along the outline of your rectangle,
without cutting out this line.

Do you need to leave a margin around your PCB you simply have
to draw the rectangle bigger.

To do the above described press the tool Rubout All Layers

Tool Rubout All Layers

Then draw your rectangle, or several rectangles for polygons if
needed. The result should look like 2.17.

Figure 2.17: Rubout All Layer
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2.5 Contour Routing

With the contour routing you define the line, where the LPKF plotter
cuts out your PCB.

2.5.1 Setting the contour

You start with defining a line, where to cut out, by pressing the
Contour Tool.

Tool Contour Routing

Then you will get a window where you should select the following:
( 2.18)

Figure 2.18: Contour Routing menu

• Aussen so the contour router tool of the LPKF will cut outside
of the rectangle defined in the Rubout All Layers.
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• For the layer select Rubout All Layer, which was defined ear-
lier.

• For the resulting layer (Ergebnis Layer) you should select Cutting
Outside

• For the used tool (Benutztes Werkzeug) select LPKFCutting
tools.

• For the tool (Werkzeug) use Contour Router 2.0mm long or
Contour Router 1.0mm long

• The Stegbreite should be 1mm or 2mm. Stegbreite defines
the width of the gap you insert later.

The result should look like ( 2.19)

Figure 2.19: Result of Contour Routing
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2.5.2 Insert Gap

In order the cut out will work, it must not be done all around, there
must be left several gaps, so that your PCB won’t fall out. And as
you probably have to dispense, the PCB has to stay fixed.

First you start marking the grey border around your PCB with
the arrow tool.

If you had a rectangle then you see eight squares, which mark the
border ( 2.20). You can step through the squares by pressing + or -,
which is sometimes easier than selecting them with the mouse.

Figure 2.20: Marked outline

Usually it is a good idea to insert the gaps in the middle of each
side of the rectangle. But you also can choose other points where to
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insert the gaps, but always insert them in a way that your PCB still
is firmly linked with the rest of the board.

To insert a gap mark one of the squares then press the tool gap

Do that with all squares you wish. The result should look like
2.21.

Figure 2.21: PCB with inserted gaps
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2.6 Insulation of layers

Now we have to calculate the tracks for the different tools of the
LPKF plotter. This is called ’insulate’.

2.6.1 Insulate Bottom

Select Bearbeiten->Isolieren ( 2.22).

Figure 2.22: Menu Insulate
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Then you get to another window where you have to select the job
and the tools available. Go to the card Job ( 2.23). There you have
to select InsulateDefaultBottom for the Bottom Layer. Then go to
the card Start ( 2.24) Select Lötseite(Bottom). For the standard
tool select Universal Cutter 0.2mm, and for the bigger tool select
Double Edged Cutter 1.0mm. These are the default tools of the
LPKF plotter. Then press Start. Now the insulation paths for the
bottom layer are calculated.

Figure 2.23: Window Insulate: Job
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Figure 2.24: Window Insulate: Start
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2.6.2 Insulate Top

In the menu select Bearbeiten->Isolieren. In the Job card select
InsulateDefaultTop. On the Start card you select the same tools
as you selected for insulating the bottom layer. For the layer you
choose Bauteilseite(Top). Then press start.

When the calculation is done you have insulated the top and the
bottom layer. If you switch off the bottom layer you should be able
to see a result like 2.25.

Figure 2.25: Possible result of insulation
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2.7 Text on your PCB

Now to another pleasing point of this documentation: Inserting text.
Surely you have the need for text on your PCB (we had!), such as
the date or the version of your PCB and nevertheless of your name.
For some people this may be the most important point. You can
insert text by pressing the tool ABC.

Then another windows opens where you can specify the layer on
which you want your text placed ( 2.26).

Figure 2.26: Window for inserting text

This can be InsulateTop for top layer or InsulateBottom for
bottom layer. When pressing OK you will be able to move the text
with your mouse. Position your text and click the left button of your
mouse.

The result should look like 2.27.
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Figure 2.27: Inserted text visible
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It may happen that other layers cover your text once you placed
it. But when you were able to drag it around, and when it was visible
before you placed it, it should be alright. This is then just a graphics
problem, or better: a problem of the displayed layers.

2.8 Exporting the data

First of all you should save you file in the CircuitCAM format, by
selecting Datei->Speichern unter.

Then select Datei->Exportieren->LPKF Fräßbohrplotter ( 2.28).
The file should be saved in the same directory as you saved the Cir-
cuitCAM file and has the name xxx.LMD, where xxx stands for the
name you gave your CircuitCAM file. We had some difficulties with
that point, because the exported file sometimes wasn’t in the direc-
tory we expected it to be. If that happens you can help yourself by
using the ’Windows 9x/NT explorer’, and then search for all *.LMD
files.
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Figure 2.28: Export the data
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2.9 Design rules for the LPKF

Due to the fact that the LPKF plotter has certain poduction restric-
tions, you have to keep several rules in mind:

• Tracks should be at least 4mil width, the min insulation width
has to be 8mil. In special cases, such as bond pads for chip on
board layouts you can use 4mil. This restriction is caused by
the week durability of the MicroCutter.

• Plated holes can be of sizes from 0.5mm to 1.4mm in 0.1mm
steps. The pad where the vacuum needle is placed on must be
about 0.4mm bigger than the drilled hole. The produced vias
will be 0.3mm smaller than the drilled hole.

• Unplated holes can range from 0.5mm to 1.5mm in diameter.
Hole sized bigger than 1.5mm will be milled out by the 1mm
ContourCutter.

Further pieces of information can be obtained from Ralf Achen-
bach.



Chapter 3

Boardmaster

3.1 Foreword

Now we finally reach our last step in the production of your PCB:
drilling and milling.

This is a step where you usually need help for the first time.
Even this documentation can’t replace the support of an experienced
person, such as Ralf Achenbach. He is the head of the ASIC test
laboratory. Many thanks to him.

BoardMaster is the controller software for the ’LPKF-Fräßbohr-
plotter’. You have to take several steps to manufacture your PCB.

The first step is to prepare the copper-board and the LPKF-
Fräßbohrplotter (from now shortly: LPKF) and setting up all the
tools during the process. When this is done, you have finished
about 50% of your total job. The preparation is as important as
the milling/drilling of your PCB, because if you make an error with
the preparation, you surely can dump your PCB later.

The next 35% is the milling/drilling and the final 15% of your
work is the dispensing, vakuum and heating of your PCB.

We didn’t intend to make a full dokumentation, because it already
exists, since BoardMaster is shipped with the LPKF, but it is a very
bulky one.

In this documentation we try to go on chronologically.

49
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One last hint: Save your file after several steps, and after each
step, where drilling and milling jobs were done.

3.2 Preparing the board

You have to start with preparing your copper-board. Its size is DIN
A4. They only differ in thickness of the board (1.0mm and 1.5mm)
and of their copper coating (18µm and 36µm). You also can choose
between boards coated with copper on one side and on two sides.

Choose one and stick it to a wooden board of the same size with
adhesive tape. (The wooden boards are in the same drawer as the
copper boards.)

Then drill a hole of 3mm diameter into the board in the center of
each short side. The holes should be about 1cm away from the edge
of the board (figure 3.1).

When you have done that, you can remove the adhesive tape.

3.3 Preparing the LPKF plotter

3.3.1 Mounting your board on the LPKF

Move the plotter head to the ’Pause’ position by Verfahre nach ->
Pause.

With the LPKF you will find two pins of 2.95mm diameter. Put
them into the drilled holes of your copper and wood boards.

On the table of the LPKF you see two orange plastic stripes. (Let
the left one on the plotter, otherwise you could change the setup.
The left pin should be in touch with a pin, which is connected on
the table.) Remove the right and fix it to the right of your boards.
Then fix the rest on the plotter.

When you attached it well, use some adhesive tape at the margin
of your board to fix it to the table of the plotter (figure 3.1).

Then load the standard tools library (asic.tol). You can do that
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Figure 3.1: Ready copper-board

by: Konfiguration->Bibliothek->Bohr Fräßkopf in the directory
C:/LPKF30/DATA/ASIC.TOL

3.3.2 Setting the workspace

Now you have to define the workspace of the plotter head.
Therefore move the head to your minimum coordinates. Imagine

a two dimensional coordinate system, with your copper board as the
first quadrant. The min position is very close to the origin of the
system. You have to pay attention, that you leave enough distance
to the edges (≈ 2cm), that the plotter isn’t able to mill/drill in the
vincinity of your left pin, which fixes the board to the table of the
LPKF.

Then choose in the menu Konfiguration-> Material-> Setzte
MIN XY

Then move the head to the maximum position. Select Konfigura-
tion-> Material-> Setzte MAX XY. Bear in mind that also the
right pin shouldn’t lie within the area you defined with setting the
two diametrical corner points of a rectangle (figure 3.2).

On this area you will be able to mill/drill.
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Figure 3.2: Set MIN XY and MAY XY

3.4 Prepare the milling/drilling

Now you prepare the plotter for the milling and drilling process. To
be able to test the right adjustment, you need test structures for the
cutter and for the drills, to be able to know if you have the right
settings (e.g. height). Then you will have to set the order of the
different phases.

3.4.1 Importing

Test structures

Usually you need the Universal Cutter 0.2mm for the standard milling
job. So import a test structure for it. Choose the menu Datei->
Importieren-> LMD and then the file
C:/LPKF30/DATA/struk0 2.lmd

Make several copies of that structure, at least three.
Then import the test structures for your plated hole. If you have

different drill sizes, just import the smallest drill.
You can do that in the menu Datei->Importieren->LMD and the

file C:/LPKF30/DATA/1 0.lmd for a 1mm diameter drill (0 6.lmd
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for a 0.6mm drill and so on).

Your PCB

In CircuitCAM you exported a file(xxx.LMD). Import that one by
choosing the menu Datei->Importieren->LMD.

Since the LPKF can’t dispense on the whole work area you defined
above, you have to place the plated holes within the dispensing area.

To display the dispense area click on the tool column and select
a vacuum cartridge. Then you will see a white outline. Within that
area you will be able to dispense. Within the area you defined as
your workspace you will be able to mill/drill.
In the following you can have a look on the icons and the menu of
Boardmaster:

In figure 3.3 you can see the toolbar of BoardMaster.

Figure 3.3: The toolbar in Boardmaster

Magnifier

Selection only in the area

Selection the whole objects in the area

Copy a object

Move a object

Move plotter to marked place

Removing structures

If you have too many structures you can remove them by choosing the
menu Bearbeiten-> Plazierung. Then select the file you intend to
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delete, and press the delete button.

3.4.2 Setting phases

Usually the phases for the whole milling/drilling process are set.
With the phases, you define the order of the different work steps.
You also select the side (top, bottom) on which a process should be
executed.

If the phases are not set, select the menu Konfiguration-> Pha-
sen and choose a process similar to the following (table 3.1):

Overview of the phases

number process side

1. Marking Drills TOP

2. Drilling TOP

3. Milling Top TOP

4. Milling Bottom BOTTOM

5. Cutting BOTTOM

6. Dispensing TOP

7. Vakuum TOP

Table 3.1: Overview of the phases

3.5 Setting the right height

This section is a very important one.

You always will need this modus operandi. After each replace-
ment of a milling tool you have to adjust the height. This is
why you should have loaded enough test structures.

You always should have activated the automatic starting of the
motor.

Automatic starting of the motor
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3.5.1 Universal Cutter

Select Milling Top, and the Universal Cutter 0.2mm. Then insert
the tool. Turn the wheel as long as you can see the Cutter from
aside the tool-head(figure ??).

Figure 3.4: tool-head

PRESS ALL- to deselect the rest of your board. Mark about 1/4
to 1/3 of a test structure (this is enough to be able to see the right
setting). Then press the plus in the menu.

Buttons for select, de-select and start

Press ’Start’. Now the plotter should work in the area of the test-
structure.

When it stopped, move the tool-head a bit aside, so that you are
able to see the milled structure. You can use a magnifying glass.
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There are now three possibilities:

• The copper was removed completely. The Universal Cutter is
set too low. So turn the wheel up. Now mark the next 1/4 or
1/3 of your test structure, and press start, . . . and so on.

• The copper wasn’t removed, nothing to see of a removement.
That means that the Universal Cutter is set to high. Turn the
wheel down. Mark the next 1/4 or 1/3 of your test structure,
and press start, . . . and so on.

• You see a structure of copper and removed copper by turns.
Now there are three possibilities:

– If the copper structures are wider than the milled structures,
then the U.Cutter is still set a bit too high. So turn the
wheel down (now in small steps, about 4 clicks or less).

– If the copper structures are smaller than the milled struc-
tures, then the U.Cutter is still set a bit too low. So turn
up the wheel (in small steps, about 4 clicks or less).

– The width of the copper structures and the milled struc-
tures is the same. So you got the right height. Proceed as
explained later.

3.6 Working procedures

To finish the PCB we have several steps to do.

3.6.1 Marking Drills

You already set the order of the phases. Now you are going to mark
the drills.

Therefore use the Universal Cutter 0.2mm. Then set the right
height as explained before (section 3.5). Mark all the drills by press-
ing All+, then press start.
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3.6.2 Drilling

Now use the right drill. Adjust the height, that the drill will get
through the copper board, but NOT through the wooden board.
Press All+ (if the drills are not marked any longer), and press Start.

3.6.3 Milling Top

Now we are milling the top of your PCB. Insert the right tool. Set
the height (section 3.5). Press All+, mark the test structures and
press - (so the test structures won’t be milled). Press Start.

Repeat the last step with all tools you need for milling the top.

3.6.4 Milling Bottom

Turn around your board.

Relative position

Before you begin with milling, you have to check, if the position of
the tool-head has changed. If it has changed, the two layers will not
be on top of each other.

To check the position, insert a tool, then zoom in to a small hole.
(To be able to see the holes on the bottom layer you have to adjust
the phases. How you do that was explained, when setting the phases.
After this step cancel the changes.)

Then manually move the plotter head to that hole. Press down
the tool-head with your hand. If the tool you inserted fits into the
drilled hole, the relative positions of the top and bottom layer should
be alright.

If NOT, you have to adjust the home position of the plotter.
Select Konfiguration -> Plotter .... Then select Entsichern.
Remember the old values of the Homeposition. Now adjust the val-
ues. Select Sichern and then press OK. Repeat the step above until
you get the right position.
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Usually you don’t have to do that, because the plotter should be
well setup.

Milling

Now do the same as in Milling Top. Then set the old homeposi-
tion.

3.6.5 Cutting

The program will tell you which tool to insert (Contour Router 2mm
or 1mm, depending on your cutout).

Adjust the height in a way, that the copper board will be cut, but
the wooden board must not be cut through.

Press All+, then press Start.

3.6.6 Dispense

Now we are getting to a rather annoying point: the dispensing.

Preparing the wooden board

First of all you have to prepare the wooden board. You have to cut
all the pieces out, which are under a plated hole. That is because the
paste will be pressed through the holes, so the board would obstruct
the flow of the paste.

But try to keep some wooden board between the areas, where are
no plated holes, so the wooden board is able to hold the copper board
on the same level, because the LPKF-tool-head always presses with
a certain force onto the copper board.

Rub off

Then you have to rub off cautiously both copper layers with emery.
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Preparing the paste

You have to prepare the paste in two syringes by pressing them from
one into the other several times. It will be more liquid then.

Figure 3.5: Tools for the plotter

Prepare the syringe

You should use a new syringe. Put in a white cap on the one side of
the syringe and press it to the bottom of it.

Then fill up the syringe by pressing the paste through the tip of
the syringe.

Then put on the metal ring over the needle. Screw on tight. Then
screw on the needle onto the syringe.

Insert it into the LPKF-head and screw it on tight, and then
attach the hose to syringe.

Adjusting pressure

Now you have to set the pressure. Start with a pressure of 1bar and
a vacuum of 0.05bar.
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Figure 3.6: Station for pressure, vacuum and light

Activate the LPKF-head manually. Do that until the paste will
come out of the needle and all the air will be removed from the
syringe.

Then again use your test holes. Mark two of them and press +,
then press start. Then check if the paste was pressed through the
hole and was coming out on the other side. If not, you have to
increase the pressure.

If the paste is dropped between two holes you have to increase the
vacuum.

Repeat the procedure of adjusting pressure and vacuum, until

• the paste is pressed through the hole, and produces a small stub
on the other side and

• the paste doesn’t drop between two holes.

When you have a small stub on the other side, you can be sure,
that the two copper layers are linked by the paste.

Then mark all (except the test holes) and press start.
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Check the paste

Then remove the copper board, but watch out NOT to smear the
paste stubs. Check if all holes have little stubs on the bottom layer.
If not then you can repeat dispensing one (or even three) time(s) with
the holes, which weren’t alright. But this should be done within 15
to 20 minutes. Otherwise the paste will dry.

If you have many plated holes where dispensing/vacuum would
take longer than half an hour you should do the dispensing/vacuum
in several independent steps.

3.6.7 Vacuum

Now we have to remove the paste in the centers of the holes. We
don’t remove it completely, because a thin layer sticks to the wall of
the hole, and this connects the two copper layers.

Now use another new syringe. Insert a cotton pad. Screw on a
new needle, with the metal ring. Then attach it to the LPKF-head,
and the hose to the syringe.

Switch off the pressure. Now go to a part of the copper board,
where you have only copper (without structures and holes). Set down
the plotter head onto the copper abd adjust the vacuum to −0.3bar.

Set down head

Then press All+, and press Start.
Then the needle will suck out the paste in the center of the holes.
If the paste wasn’t sucked out on the first turn, repeat the vacuum,

until the paste is sucked out well.

3.6.8 Baking

Now remove the wooden board, and put the copper board into the
oven. Pay attention that you don’t smear the paste.

Then heat the oven to 160◦C and set the timer to half an hour.
Now wait until your pizza is crispy an the cheese is golden.
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